diff --git a/recipes-ros/catkin/catkin_0.5.85.bb b/recipes-ros/catkin/catkin_0.5.85.bb
index 1b0cbcfc3c3a4db7f00b44fb77ce6285a88d890b..3c6304d31eee85ba5defa675efbeaa151189c2d6 100644
--- a/recipes-ros/catkin/catkin_0.5.85.bb
+++ b/recipes-ros/catkin/catkin_0.5.85.bb
@@ -26,6 +26,6 @@ FILES_${PN}-dev += "\
 RDEPENDS_${PN}_class-native = ""
 RDEPENDS_${PN} = "cmake make binutils binutils-symlinks gcc gcc-symlinks g++ g++-symlinks \
     python-catkin-pkg python-argparse python-misc python-multiprocessing \
-    python-shell python-subprocess python-xml"
+    python-shell python-subprocess python-xml python-pkgutil"
 
 BBCLASSEXTEND += "native"
diff --git a/recipes-ros/common-msgs/nav-msgs_1.10.6.bb b/recipes-ros/common-msgs/nav-msgs_1.10.6.bb
index 6b5825efc8cbe7bef12a053674bc8052cb6956d9..9e997f3696102b9817e0abc83c81542a8b879c52 100644
--- a/recipes-ros/common-msgs/nav-msgs_1.10.6.bb
+++ b/recipes-ros/common-msgs/nav-msgs_1.10.6.bb
@@ -6,3 +6,5 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc
 DEPENDS = "actionlib-msgs geometry-msgs"
 
 require common-msgs.inc
+
+RDEPENDS_${PN} = "actionlib-msgs"
diff --git a/recipes-ros/dynamic-reconfigure/dynamic-reconfigure_1.5.34.bb b/recipes-ros/dynamic-reconfigure/dynamic-reconfigure_1.5.34.bb
index 2571f05388b3631aa8d37dfe8aa54698707b3352..0a779457fd076b29bc89b69fe1e6f29aa3c9b283 100644
--- a/recipes-ros/dynamic-reconfigure/dynamic-reconfigure_1.5.34.bb
+++ b/recipes-ros/dynamic-reconfigure/dynamic-reconfigure_1.5.34.bb
@@ -15,4 +15,4 @@ S = "${WORKDIR}/${ROS_SP}"
 
 inherit catkin
 
-RDEPENDS_${PN} = "roslib"
+RDEPENDS_${PN} = "roslib rosservice"
diff --git a/recipes-ros/geometry/tf_1.10.8.bb b/recipes-ros/geometry/tf_1.10.8.bb
index a02855cd97d7970461ab59c223ab18e9dc3035c2..82fe6e7e876b51f69916bb610a44ccd12b759a89 100644
--- a/recipes-ros/geometry/tf_1.10.8.bb
+++ b/recipes-ros/geometry/tf_1.10.8.bb
@@ -8,3 +8,5 @@ DEPENDS = "angles geometry-msgs message-filters sensor-msgs tf2-ros"
 require geometry.inc
 
 SRC_URI += "file://0001-rostest-is-optional.patch;striplevel=2"
+
+RDEPENDS_${PN} = "python-numpy"
diff --git a/recipes-ros/robot-model/joint-state-publisher_1.10.18.bb b/recipes-ros/robot-model/joint-state-publisher_1.10.18.bb
index 75e40d42fd98f0ddbe86a8be9227f9a185aa6722..1839fd3a52fdc506380bd306846241078c08cd9e 100644
--- a/recipes-ros/robot-model/joint-state-publisher_1.10.18.bb
+++ b/recipes-ros/robot-model/joint-state-publisher_1.10.18.bb
@@ -7,3 +7,5 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc
 DEPENDS = "rospy wxpython sensor-msgs"
 
 require robot-model.inc
+
+RDEPENDS_${PN} = "wxpython"
diff --git a/recipes-ros/ros-comm/rosservice_1.10.1.bb b/recipes-ros/ros-comm/rosservice_1.10.1.bb
index 344328a54f252437854253229549194b2cded045..ad506973ee4629475cb64d7a438433053cfe8d19 100644
--- a/recipes-ros/ros-comm/rosservice_1.10.1.bb
+++ b/recipes-ros/ros-comm/rosservice_1.10.1.bb
@@ -6,3 +6,5 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=d566ef916e9de
 require ros-comm.inc
 
 ROS_PKG_SUBDIR = "tools"
+
+RDEPENDS_${PN} = "rosmsg"