diff --git a/recipes-core/images/core-image-ros-world.bb b/recipes-core/images/core-image-ros-world.bb
new file mode 100644
index 0000000000000000000000000000000000000000..c725110d2fe8c34845eeeb62cec21e086fe4b56e
--- /dev/null
+++ b/recipes-core/images/core-image-ros-world.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "An image with packagegroup-ros-world installed"
+
+IMAGE_INSTALL = "packagegroup-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP} ${CORE_IMAGE_EXTRA_INSTALL}"
+
+IMAGE_LINGUAS = " "
+
+LICENSE = "MIT"
+
+inherit core-image
+
+IMAGE_ROOTFS_SIZE = "8192"
+
+# remove not needed ipkg informations
+ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files"
+
+IMAGE_INSTALL += "packagegroup-ros-world"